Does StampPDF 2.7 work with Acrobat 8?

StampPDF 2.7 is supported under Acrobat 5, 6, and 7.  StampPDF 2.7 was released in 2001 and is not supported under Acrobat 8.  

StampPDF 5.0.5 is the current shipping version of the plug-in and supports Acrobat 7, and all subsequent versions, including Acrobat 8, 9, X and XI.

If you would like to upgrade, please contact our Sales Department.